using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"http:\/\/www\.example\.com\/highlights\/cat\/(.*)";
string input = @"http://www.example.com/highlights/cat/all-about-clothing/";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}