re = /http:\/\/www\.example\.com\/highlights\/cat\/(.*)/
str = 'http://www.example.com/highlights/cat/all-about-clothing/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end