$re = '/http:\/\/www\.example\.com\/highlights\/cat\/(.*)/';
$str = 'http://www.example.com/highlights/cat/all-about-clothing/';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);