using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"States(?=\()";
string input = @"create Table dbo.States(
int int not null identity,
States nvarchar(100))";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}