$re = '/States(?=\()/m';
$str = 'create Table dbo.States(
int int not null identity,
States nvarchar(100))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);