re = /States(?=\()/m
str = 'create Table dbo.States(
int int not null identity,
States nvarchar(100))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end