using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*,$)(?:""((?:\\.|[^""])*)""|([^,]*))(?:[,])";
string input = @""",huhu,""hel lo"",world,
hello,""worl\""d"",end,
hello,worl""d,end,
hello, world, nomatch";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}