re = /(?=.*,$)(?:"((?:\\.|[^"])*)"|([^,]*))(?:[,])/m
str = '"",huhu,"hel lo",world,
hello,"worl\\"d",end,
hello,worl"d,end,
hello, world, nomatch'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end