$re = '/(?=.*,$)(?:"((?:\\\\.|[^"])*)"|([^,]*))(?:[,])/m';
$str = '"",huhu,"hel lo",world,
hello,"worl\\"d",end,
hello,worl"d,end,
hello, world, nomatch';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);