import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w[\\w\\s]+func[\\w\\s()]+(\\{(?:[^\\{\\}]*|[\\w\\s();]*?\\{[\\w\\s();]*?\\}[\\w\\s();]*?)*\\})";
final String string = "override func something() { \n\n"
+ "halloworld() { };\n\n"
+ "halloworld() { }; \n\n\n"
+ "}\n\n"
+ "override func something() { \n\n"
+ "halloworld(); \n\n\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}