re = /\w[\w\s]+func[\w\s()]+({(?:[^{}]*|[\w\s();]*?{[\w\s();]*?}[\w\s();]*?)*})/
str = 'override func something() {
halloworld() { };
halloworld() { };
}
override func something() {
halloworld();
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end