$re = '/\w[\w\s]+func[\w\s()]+({(?:[^{}]*|[\w\s();]*?{[\w\s();]*?}[\w\s();]*?)*})/s';
$str = 'override func something() {
halloworld() { };
halloworld() { };
}
override func something() {
halloworld();
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);