using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"select|\/\*\*\/";
string input = @"select
selectbar
fooselect
fooselectbar
/**/
/**/bar
foo/**/
foo/**/bar
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}