re = /select|\/\*\*\//
str = 'select
selectbar
fooselect
fooselectbar
/**/
/**/bar
foo/**/
foo/**/bar
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end