package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`select|\/\*\*\/`)
var str = `select
selectbar
fooselect
fooselectbar
/**/
/**/bar
foo/**/
foo/**/bar
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}