using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\n( *\\n)+";
string input = @"word boundaries are odd
\n
\n\n
\n\n\n
\n \n
\n \n \n
\n \n
\n \n\n The quick brown fox \n \n \n \n \n \n \n \n The \nquick \nbrown fox\n
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}