$re = '/\\\\n( *\\\\n)+/';
$str = 'word boundaries are odd
\\n
\\n\\n
\\n\\n\\n
\\n \\n
\\n \\n \\n
\\n \\n
\\n \\n\\n The quick brown fox \\n \\n \\n \\n \\n \\n \\n \\n The \\nquick \\nbrown fox\\n
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);