import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\\n( *\\\\n)+";
final String string = "word boundaries are odd\n"
+ "\\n\n"
+ "\\n\\n\n"
+ "\\n\\n\\n\n"
+ "\\n \\n\n"
+ "\\n \\n \\n\n"
+ "\\n \\n\n"
+ "\\n \\n\\n The quick brown fox \\n \\n \\n \\n \\n \\n \\n \\n The \\nquick \\nbrown fox\\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}