$re = '/(.+?)\s(.+?)\s(.+)/m';
$str = 'Reto P. Burger';
$subst = "\3-\2\-\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;