import re
regex = re.compile(r"(.+?)\s(.+?)\s(.+)", flags=re.MULTILINE)
test_str = "Reto P. Burger"
subst = "\\3-\\2\\-\\1"
result = regex.sub(subst, test_str)
if result:
print(result)