re = /(.+?)\s(.+?)\s(.+)/m
str = 'Reto P. Burger'
subst = '\\3-\\2\\-\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result