import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*?(one))(?=.*?(two))(?=.*?(three))(?:(?:\\1|\\2|\\3);?){3}$";
final String string = "one;two;three\n"
+ "two;one;three\n"
+ "three;two;one\n"
+ "one;one;two\n"
+ "three;one;two\n"
+ "onetwothree";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}