$re = '/^(?=.*?(one))(?=.*?(two))(?=.*?(three))(?:(?:\1|\2|\3);?){3}$/m';
$str = 'one;two;three
two;one;three
three;two;one
one;one;two
three;one;two
onetwothree';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);