const regex = /(?sm)^0(?:(?!^0).)*?(?:kryptonite|stalagmite)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?sm)^0(?:(?!^0).)*?(?:kryptonite|stalagmite)', 'g')
const str = `00:20314 lorem ipsum
want this
kryptonite
00:02314 quux
padding
dont want this
00:03124 foo
neither this
00:01324 foo
but we want this
stalagmite
00:02134 tralala
not this
00:03124 bar foo
and we want this
kryptonite but not this(!)
00:02134 foo bar
and not this either
00:01234 dolor sit amet
EOF`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}