use strict;
my $str = '00:20314 lorem ipsum
want this
kryptonite
00:02314 quux
padding
dont want this
00:03124 foo
neither this
00:01324 foo
but we want this
stalagmite
00:02134 tralala
not this
00:03124 bar foo
and we want this
kryptonite but not this(!)
00:02134 foo bar
and not this either
00:01234 dolor sit amet
EOF';
my $regex = qr/(?sm)^0(?:(?!^0).)*?(?:kryptonite|stalagmite)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}