# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?sm)^0(?:(?!^0).)*?(?:kryptonite|stalagmite)"
test_str = ("00:20314 lorem ipsum\n"
" want this\n"
" kryptonite\n\n"
"00:02314 quux\n"
" padding\n"
" dont want this\n\n"
"00:03124 foo\n"
" neither this\n\n"
"00:01324 foo\n"
" but we want this\n"
" stalagmite\n\n"
"00:02134 tralala\n"
" not this\n\n"
"00:03124 bar foo\n"
" and we want this\n"
" kryptonite but not this(!)\n\n"
"00:02134 foo bar\n"
" and not this either\n\n"
"00:01234 dolor sit amet\n"
" EOF")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.