$re = '/^[a-zA-Z][a-zA-Z0-9]*(?:\.[0-9]+(?:\.[a-zA-Z][a-zA-Z0-9]*\.[0-9]+)*)?$/m';
$str = 'January.313
January
January.31.Feb.6
GMI3.0.N.1
January.31.Feb.6.March.7
April.May
1.2
44';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);