// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-zA-Z][a-zA-Z0-9]*(?:\.[0-9]+(?:\.[a-zA-Z][a-zA-Z0-9]*\.[0-9]+)*)?$").unwrap();
let string = "January.313
January
January.31.Feb.6
GMI3.0.N.1
January.31.Feb.6.March.7
April.May
1.2
44";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}