re = /^[a-zA-Z][a-zA-Z0-9]*(?:\.[0-9]+(?:\.[a-zA-Z][a-zA-Z0-9]*\.[0-9]+)*)?$/m
str = 'January.313
January
January.31.Feb.6
GMI3.0.N.1
January.31.Feb.6.March.7
April.May
1.2
44'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end