package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\[user.*?/user]`)
var str = `I will add [USER=1234]@banana1[/USER] to the chat`
var substitution = "usermention"
fmt.Println(re.ReplaceAllString(str, substitution))
}