$re = '~\[user.*?/user]~i';
$str = 'I will add [USER=1234]@banana1[/USER] to the chat';
$subst = "usermention";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;