re = /\[user.*?\/user]/i
str = 'I will add [USER=1234]@banana1[/USER] to the chat'
subst = 'usermention'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result