using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\d{4}[a-zA-Z]{2} )[^,\]]+";
string input = @"[Jon Doe_Sesamstreet 10_2805JD GOUDA, DENNIS PEPERSTRAATE_Regentesseplantsoen 56_2855CJ Cappele aan de Ijsel]
[A. Smith_Broekstraat 99-A_4032JZ MAASBRACHT, A. GOEDBLOED 72_9332KL MAASBRACHT]
[T. Loyal_Da Smeet 6_3381AZ Laag Zuthm, T. Oppers</strong>ACSI (Ton)_Loyal 99_6688DR Andelst-Jon Verkade_Nederland]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}