$re = '/(?<=\d{4}[a-zA-Z]{2} )[^,\]]+/';
$str = '[Jon Doe_Sesamstreet 10_2805JD GOUDA, DENNIS PEPERSTRAATE_Regentesseplantsoen 56_2855CJ Cappele aan de Ijsel]
[A. Smith_Broekstraat 99-A_4032JZ MAASBRACHT, A. GOEDBLOED 72_9332KL MAASBRACHT]
[T. Loyal_Da Smeet 6_3381AZ Laag Zuthm, T. Oppers</strong>ACSI (Ton)_Loyal 99_6688DR Andelst-Jon Verkade_Nederland]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);