import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\d{4}[a-zA-Z]{2} )[^,\\]]+";
final String string = "[Jon Doe_Sesamstreet 10_2805JD GOUDA, DENNIS PEPERSTRAATE_Regentesseplantsoen 56_2855CJ Cappele aan de Ijsel]\n\n"
+ "[A. Smith_Broekstraat 99-A_4032JZ MAASBRACHT, A. GOEDBLOED 72_9332KL MAASBRACHT]\n\n"
+ "[T. Loyal_Da Smeet 6_3381AZ Laag Zuthm, T. Oppers</strong>ACSI (Ton)_Loyal 99_6688DR Andelst-Jon Verkade_Nederland]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}