#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^#start of line" & @CRLF & _
"(?![^\n!]*!{2,})" & @CRLF & _
"(?=[^_\n]*_[^_]*) #if _ exists, then:" & @CRLF & _
"([^_:]+) #mandatory group 1" & @CRLF & _
"((?=:[^:\n]):[^:_(\n]+|) #optional group 2" & @CRLF & _
"(_(?!_)) #group 3 mandatory" & @CRLF & _
"([^_\-(\n]+) # group 4 mandatory" & @CRLF & _
"\( #mandatory (" & @CRLF & _
"([^()\n]+) # group 5 mandatory" & @CRLF & _
"\) #mandatory )" & @CRLF & _
"((?=!)!|) # group 6 optional" & @CRLF & _
"((?=:[^!:@\n]):[^!:@\n]+|) # group 7 optional" & @CRLF & _
"((?=::[^!:@\n])::[^!:@\n]+|) #group 8 optional" & @CRLF & _
"((?=@[^!:@\n])@[^!:@\n]+|) #group 9 optional" & @CRLF & _
"$ #end of line"
Local $sString = "# OK - Matches all components if all are provided" & @CRLF & _
"contextClassName:pc_ruleName(param_One paramTwo)!:pc::pe@media" & @CRLF & _
"" & @CRLF & _
"# OK - Return group 2 blank when no : exists before _ which is group 3" & @CRLF & _
"contextClassName_ruleName(param_One paramTwo)!:pc::pe@media" & @CRLF & _
"" & @CRLF & _
"# OK - When ! is not provided return group 6 blank" & @CRLF & _
"contextClassName_ruleName(param_One paramTwo):pc::pe@media" & @CRLF & _
"" & @CRLF & _
"# NOTOK - More than one consecutive !" & @CRLF & _
"contextClassName_ruleName(param_One paramTwo)!!:pc::pe@media" & @CRLF & _
"" & @CRLF & _
"# NOTOK - 3 More than two : at instruction tail" & @CRLF & _
"contextClassName_ruleName(param_One paramTwo):::pe@media" & @CRLF & _
"" & @CRLF & _
"# OK - 2 At instruction tail :: is resolved to group 8 " & @CRLF & _
"contextClassName_ruleName(param_One paramTwo)::pe@media" & @CRLF & _
"" & @CRLF & _
"# OK - 1 At instruction tail : is resolved to group 7 " & @CRLF & _
"contextClassName_ruleName(param_One paramTwo):pe@media" & @CRLF & _
"" & @CRLF & _
"# OK - At instruction start : followed by chars" & @CRLF & _
"contextClassName:pc_ruleName(param_One paramTwo):pe@media" & @CRLF & _
"" & @CRLF & _
"# NOTOK - At instruction start : not followed by chars" & @CRLF & _
"contextClassName:_ruleName(param_One paramTwo):pe@media" & @CRLF & _
"" & @CRLF & _
"# NOTOK - At instruction start :: followed by chars" & @CRLF & _
"contextClassName::pc_ruleName(param_One paramTwo):pe@media" & @CRLF & _
"" & @CRLF & _
"# OK - Whole instruction tail is optional " & @CRLF & _
"contextClassName:pc_ruleName(param_One paramTwo)" & @CRLF & _
"" & @CRLF & _
"# OK - Parameter value can contain anything" & @CRLF & _
"contextClassName:pc_ruleName(param_One param#$^Two)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")