import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^#start of line\n"
+ "(?![^\\n!]*!{2,})\n"
+ "(?=[^_\\n]*_[^_]*) #if _ exists, then:\n"
+ "([^_:]+) #mandatory group 1\n"
+ "((?=:[^:\\n]):[^:_(\\n]+|) #optional group 2\n"
+ "(_(?!_)) #group 3 mandatory\n"
+ "([^_\\-(\\n]+) # group 4 mandatory\n"
+ "\\( #mandatory (\n"
+ "([^()\\n]+) # group 5 mandatory\n"
+ "\\) #mandatory )\n"
+ "((?=!)!|) # group 6 optional\n"
+ "((?=:[^!:@\\n]):[^!:@\\n]+|) # group 7 optional\n"
+ "((?=::[^!:@\\n])::[^!:@\\n]+|) #group 8 optional\n"
+ "((?=@[^!:@\\n])@[^!:@\\n]+|) #group 9 optional\n"
+ "$ #end of line";
final String string = "# OK - Matches all components if all are provided\n"
+ "contextClassName:pc_ruleName(param_One paramTwo)!:pc::pe@media\n\n"
+ "# OK - Return group 2 blank when no : exists before _ which is group 3\n"
+ "contextClassName_ruleName(param_One paramTwo)!:pc::pe@media\n\n"
+ "# OK - When ! is not provided return group 6 blank\n"
+ "contextClassName_ruleName(param_One paramTwo):pc::pe@media\n\n"
+ "# NOTOK - More than one consecutive !\n"
+ "contextClassName_ruleName(param_One paramTwo)!!:pc::pe@media\n\n"
+ "# NOTOK - 3 More than two : at instruction tail\n"
+ "contextClassName_ruleName(param_One paramTwo):::pe@media\n\n"
+ "# OK - 2 At instruction tail :: is resolved to group 8 \n"
+ "contextClassName_ruleName(param_One paramTwo)::pe@media\n\n"
+ "# OK - 1 At instruction tail : is resolved to group 7 \n"
+ "contextClassName_ruleName(param_One paramTwo):pe@media\n\n"
+ "# OK - At instruction start : followed by chars\n"
+ "contextClassName:pc_ruleName(param_One paramTwo):pe@media\n\n"
+ "# NOTOK - At instruction start : not followed by chars\n"
+ "contextClassName:_ruleName(param_One paramTwo):pe@media\n\n"
+ "# NOTOK - At instruction start :: followed by chars\n"
+ "contextClassName::pc_ruleName(param_One paramTwo):pe@media\n\n"
+ "# OK - Whole instruction tail is optional \n"
+ "contextClassName:pc_ruleName(param_One paramTwo)\n\n"
+ "# OK - Parameter value can contain anything\n"
+ "contextClassName:pc_ruleName(param_One param#$^Two)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}