# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^#start of line
(?![^\n!]*!{2,})
(?=[^_\n]*_[^_]*) #if _ exists, then:
([^_:]+) #mandatory group 1
((?=:[^:\n]):[^:_(\n]+|) #optional group 2
(_(?!_)) #group 3 mandatory
([^_\-(\n]+) # group 4 mandatory
\( #mandatory (
([^()\n]+) # group 5 mandatory
\) #mandatory )
((?=!)!|) # group 6 optional
((?=:[^!:@\n]):[^!:@\n]+|) # group 7 optional
((?=::[^!:@\n])::[^!:@\n]+|) #group 8 optional
((?=@[^!:@\n])@[^!:@\n]+|) #group 9 optional
$ #end of line
"""
test_str = ("# OK - Matches all components if all are provided\n"
"contextClassName:pc_ruleName(param_One paramTwo)!:pc::pe@media\n\n"
"# OK - Return group 2 blank when no : exists before _ which is group 3\n"
"contextClassName_ruleName(param_One paramTwo)!:pc::pe@media\n\n"
"# OK - When ! is not provided return group 6 blank\n"
"contextClassName_ruleName(param_One paramTwo):pc::pe@media\n\n"
"# NOTOK - More than one consecutive !\n"
"contextClassName_ruleName(param_One paramTwo)!!:pc::pe@media\n\n"
"# NOTOK - 3 More than two : at instruction tail\n"
"contextClassName_ruleName(param_One paramTwo):::pe@media\n\n"
"# OK - 2 At instruction tail :: is resolved to group 8 \n"
"contextClassName_ruleName(param_One paramTwo)::pe@media\n\n"
"# OK - 1 At instruction tail : is resolved to group 7 \n"
"contextClassName_ruleName(param_One paramTwo):pe@media\n\n"
"# OK - At instruction start : followed by chars\n"
"contextClassName:pc_ruleName(param_One paramTwo):pe@media\n\n"
"# NOTOK - At instruction start : not followed by chars\n"
"contextClassName:_ruleName(param_One paramTwo):pe@media\n\n"
"# NOTOK - At instruction start :: followed by chars\n"
"contextClassName::pc_ruleName(param_One paramTwo):pe@media\n\n"
"# OK - Whole instruction tail is optional \n"
"contextClassName:pc_ruleName(param_One paramTwo)\n\n"
"# OK - Parameter value can contain anything\n"
"contextClassName:pc_ruleName(param_One param#$^Two)")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.