#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*(\.[a-zA-Z0-9]*)"
Local $sString = ".myClass{color:red;}" & @CRLF & _
".myClass .myOtherClass{color:green;}" & @CRLF & _
"#something .somethingElse{color:blue;}" & @CRLF & _
".something #myIdhere{color:purple;}" & @CRLF & _
"#myId {color:black}" & @CRLF & _
".myClass1, .myClass2{colour:green}" & @CRLF & _
".myClass span{colour:purple}" & @CRLF & _
".myPseudo:after{}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")