package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*(\.[a-zA-Z0-9]*)`)
var str = `.myClass{color:red;}
.myClass .myOtherClass{color:green;}
#something .somethingElse{color:blue;}
.something #myIdhere{color:purple;}
#myId {color:black}
.myClass1, .myClass2{colour:green}
.myClass span{colour:purple}
.myPseudo:after{}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}