import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*(\\.[a-zA-Z0-9]*)";
final String string = ".myClass{color:red;}\n"
+ ".myClass .myOtherClass{color:green;}\n"
+ "#something .somethingElse{color:blue;}\n"
+ ".something #myIdhere{color:purple;}\n"
+ "#myId {color:black}\n"
+ ".myClass1, .myClass2{colour:green}\n"
+ ".myClass span{colour:purple}\n"
+ ".myPseudo:after{}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}