using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*\/>\w+|\w+(?=""\S)";
string input = @"TextTextTextTextTextTextTextText""signed_request"" value=""Random Value"" />TextTextTextTextTextTextTextTextTextText";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}