re = /\s*\/>\w+|\w+(?="\S)/i
str = 'TextTextTextTextTextTextTextText"signed_request" value="Random Value" />TextTextTextTextTextTextTextTextTextText'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end