const regex = /(^|[^a-zA-Z0-9.])left/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|[^a-zA-Z0-9.])left', 'gi')
const str = `left.position.left = leftContent.left.posleft`;
const subst = `$1a`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);