$re = '/(^|[^a-zA-Z0-9.])left/i';
$str = 'left.position.left = leftContent.left.posleft';
$subst = "$1a";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;