import re
regex = re.compile(r"(?<=;)(?![^{]*})|(?<=}(?!$))", flags=re.MULTILINE)
test_str = "a;b{c;d;}e{f;}"
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)