re = /(?<=;)(?![^{]*})|(?<=}(?!$))/m
str = 'a;b{c;d;}e{f;}'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result