use strict;
my $str = '<p>The quick fox</p>';
my $regex = qr/(.+)\1+/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";