$re = '/(.+)\1+/m';
$str = '<p>The quick fox</p>';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;