use strict;
my $str = 'some-thing.org
some-thing.org.sg
some-thing.com
some-thing.com.sg
some-thing.com.*
some1-thing.com
sòme1-thing.org
some-thing
some-thing.moc';
my $regex = qr/^(?=[\p{L}0-9]+-[\p{L}0-9]+)([^.]+\.(?:org|com).*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}